April 10, 2013

Exchange 2010 - EMC connection issue

Changes: 
Client access servers were updated with SP2 UR6. Management workstation where EMC installed was also updated with this Update Rollup.

After updates we got EMC error on Management workstation:
The attempt to connect to http://ExchangeServerName/PowerShell using "Kerberos" authentication failed. Connecting to remote server failed with the following message: Logon failure: unknown user name or bad password. For more information see the about_Remote_Troubleshooting Help topic.

Resolution:
Step 1. Enable and disable RemotePowerShellEnabled for exchange user:

Get-User UserName | fl *RemotePowerShellEnabled*
Set-User UserName -RemotePowerShellEnabled $false
Set-User UserName -RemotePowerShellEnabled $true

Step 2. Hide/Unhide user mailbox from Exchange address lists.

Step 3. Re-install Update Rollup on management station. 

Conclusion: 
UR was installed by user from different domain with SID history of current user. Issue was resolved by making changes on mailbox (Step 1-2) and reinstalling Update Rollup with right account.

Useful links:
Connect Remote Exchange Management Shell to an Exchange Server - http://technet.microsoft.com/en-us/library/dd297932%28v=exchg.141%29.aspx
Enable Remote Exchange Management Shell for a User - http://technet.microsoft.com/en-us/library/dd298084%28v=exchg.141%29.aspx
Managing Exchange 2010 with Remote PowerShell - http://www.mikepfeiffer.net/2010/02/managing-exchange-2010-with-remote-powershell/

Final Resolution:
Remove from vault stored passwords in Credential Manager associated with Exchange servers on management workstation. 

No comments:

Post a Comment